Autor Thema: Raster Filter Shapefile being Ignored by IMC  (Gelesen 299 mal)

Offline Egret

  • Jungbrut
  • *
  • Beiträge: 3
    • My/Mein Tackle Equipment: shimano
  • My/Mein Echo Equipment: HDS-7 Carbon, Simrad and others
Raster Filter Shapefile being Ignored by IMC
« am: 25 März 2018, 18:50:58 »
Hello:
I am creating a map with Raster Imagery and after some research understand that to avoid Black borders at the edges I need to limit the rendering to the edge of the blocks created by the Software.

To this end, I created a block list for different resolutions so I could see the edges of the blocks for my map area.  I then created some shape files to exactly mirror those edges that I intend to use as Raster Filter Shapefiles in the IMC advanced options to limit the Raster output in the IMC to the limit of my shapefiles (just to the edge of the outside blocks).

I am running IMC version 7.4.31
My Imagery is JP2000 format
My Raster Projection is GEO WGS 84
The Shapefiles I created are in projection GEO WGS84.  I checked and the shapefiles are polygon and not Multi-patch.  Each .shp shapefile has a .cpg, .dbf, .prj and .shx associated file.  It looks totally good when loaded in Global mapper.

In the IMC, I loaded my Image data folder/file and also the the path of one of my created polygon shapefiles into the Raster Filter Boundary.
I am finding that the IMC will run and create the AT5s, however, the Filter Image Boundary shapefile is being ignored and the IMC is processing all of the loaded Raster.  Therefore, the edges of the created raster fall outside of the block boundary and it creates the black borders.

I have tried all kinds of different projections and different attribute changes to the Boundary shapefiles but the result is always the same where the Raster Filter shapefile is totally ignored.

I have no idea what to do to fix this.

I am sure this is a simple fix but I am at a total loss to find a solution after of a couple of days of experimenting.

Can anyone advise how to resolve this?  Thanks!

Online gregory

  • Insight Map Creator
  • *
  • Beiträge: 639
Re: Raster Filter Shapefile being Ignored by IMC
« Antwort #1 am: 26 März 2018, 13:39:15 »
As much as I remember that setting, it should be in the same projection as defined in the Advanced Options.

The setting won't exclude any tile that touches the shapefile.

I haven't tested this setting in a while but it's something I can do if you find this functionality isn't working.

Offline Egret

  • Jungbrut
  • *
  • Beiträge: 3
    • My/Mein Tackle Equipment: shimano
  • My/Mein Echo Equipment: HDS-7 Carbon, Simrad and others
Re: Raster Filter Shapefile being Ignored by IMC
« Antwort #2 am: 26 März 2018, 14:50:21 »
Thank you Greg.  Please try that for me and let me know.
If I understand your response correctly, I should try to set the Projection in Advanced to GEO wgs84 and also select that same projection option as opposed to just using "Standard"?

I think I have tried every setting and different projections with no results including doing that. I tried it again that way with no success.  The entire loaded image is produced and the shapefile boundary is ignored. 
Really frustrating.  I have spent two days trying to get it to work trying different shapefiles and photos and projections and settings.  Each time the full image will render but only as long as the shapefile is in the same projection as the image.  Can I email you one of the small test shapefiles I created to test?

Online gregory

  • Insight Map Creator
  • *
  • Beiträge: 639
Re: Raster Filter Shapefile being Ignored by IMC
« Antwort #3 am: 26 März 2018, 15:17:53 »
I have test files to work from.

Online gregory

  • Insight Map Creator
  • *
  • Beiträge: 639
Re: Raster Filter Shapefile being Ignored by IMC
« Antwort #4 am: 26 März 2018, 16:42:32 »
The functionality is working exactly the way I would expect it to.

Your issue is in your settings or in your expectations.

Offline Egret

  • Jungbrut
  • *
  • Beiträge: 3
    • My/Mein Tackle Equipment: shimano
  • My/Mein Echo Equipment: HDS-7 Carbon, Simrad and others
Re: Raster Filter Shapefile being Ignored by IMC
« Antwort #5 am: 26 März 2018, 16:49:03 »
I dont know what settings to use then for each field.
Maybe there is something amiss with my software.

 Can you email one of those shapefiles you used and advise exactly what settings you used for each required field?
Can I email you the shapefile I was testing and the small image to see if you can get it to work?

IAbout a year ago I used this filter  before with success and I believe I am following the exact same procedure as I did previously.  What would cause the shapefile to be ignored?